Nueva vulnerabilidad en routers Linksys. ¿Es tan peligrosa como dicen?

Durante los últimos días se ha venido comentando una posible nueva vulnerabilidad en cierto modelo de router Linksys. Según la empresa DefenseCode esta vulnerabilidad estaría presente incluso en la versión más reciente del firmware publicado para este modelo, a pesar de que avisaron a Cisco hace meses y estos comunicaron que la vulnerabilidad había sido corregida.

eset_nod32_WRT54GL

Para demostrar que este agujero de seguridad sigue estando presente incluso en la última versión del firmware oficial disponible (4.30.14), los investigadores que la descubrieron han publicado un vídeo donde se ve cómo acceden a un router Linksys vulnerable y consiguen una shell en el propio router, consiguiendo su control.

No obstante, y a pesar de este vídeo, siguen habiendo dudas entre varios investigadores sobre si el exploit realmente funciona tras la actualización del firmware a la última versión disponible. Tal y como apunta nuestro compañero de profesión Paul Ducklin de Sophos en un post sobre este mismo tema, el vídeo podría haber sido preparado para que mostrara esos datos sin que se estuviese produciendo una intrusión real en el router.

Independientemente de si el vídeo es real y esta vulnerabilidad sigue estando presente en los routers indicados con la última versión del firmware instalado, se requiere que el atacante esté conectado a la red interna en la que se encuentra el router para poder usar el exploit. Si la red Wi-Fi en la que se encuentra el router vulnerable está protegida con un sistema de cifrado robusto (WPA sería una buena opción) y dispone de una contraseña fuerte, difícilmente conseguirá un atacante acceder a ella. En el supuesto caso de que el ataque se produzca por tener acceso físico al router, probablemente la existencia de este exploit sea el menor de nuestros problemas.

Además, solo la versión basada en Linux del router Linksys WRT54GL se ve afectada. Esta versión lleva bastantes años en circulación y, debido a sus prestaciones, es muy usada por gente con conocimientos para realizar modificaciones e instalar otros firmwares distintos del oficial, evitando así verse afectados por esta vulnerabilidad.

Así las cosas, parece que esta “grave” vulnerabilidad se ve bastante mitigada y sus víctimas potenciales podrían no ser tantas como la empresa descubridora de este fallo afirma. En cualquier caso, nunca está de más revisar si nuestro router (sea del fabricante que sea) dispone de la versión más reciente de su firmware para ahorrarnos disgustos innecesarios.

Josep Albors

2 Comments

Añadir un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *