Vulnerabilidad en Samba permite ejecutar código remotamente con permisos de root

Una nueva vulnerabilidad ha sido solucionada recientemente en el software de código abierto Samba, utilizado por una gran cantidad de sistemas en todo el mundo para acceder a archivos y recursos compartidos tanto en una red local como a través de Internet. Este software continúa siendo soportado y utilizado en la mayoría de sistemas operativos actuales, incluyendo Windows, Linux y macOS, por lo que cualquier fallo de seguridad grave que le afecte debe ser tomado en cuenta.

Ejecución de código remota

La vulnerabilidad, catalogada como CVE-2021-44142, permite su explotación remota por parte de un atacante para conseguir la ejecución de código con permisos de root/administrador en aquellos servidores que estén ejecutando una versión vulnerable del software.

Samba está implementado en muchos sistemas operativos actuales como Windows, derivados de UNIX como Linux, Solaris, AIX y las variantes BSD, lo que también incluye a macOS, entre otros, y se trata de una reimplementación del protocolo de red SMB, permitiendo a aquellos sistemas que no sean Windows compartir recursos a través de una red con el sistema operativo de Microsoft.

Este agujero de seguridad afecta a todas las versiones de Samba anteriores a la 4.13.17, permitiendo a un atacante explotarla sin necesidad de interacción por parte del usuario. Por suerte, ya se encuentran disponibles versiones de Samba que solucionan esta vulnerabilidad como la 4.13.17, 4.14.12 y la 4.15.5, así como también parches de seguridad que se recomienda aplicar lo antes posible.

Un problema que se repite

No es la primera vez se observa una vulnerabilidad de este calibre afectando a Samba, y las posibilidades que presenta para un atacante son muy atractivas, especialmente en lo que representa a la propagación de una amenaza dentro de una red. Recordemos que Samba es una implementación de código abierto del protocolo SMB original y que se utiliza en redes Windows.

Precisamente, una vulnerabilidad grave revelada en el protocolo SMB fue aprovechada hace años para crear varios exploits como EternalBlue o DoublePulsar, lo que, unido a la publicación de estos exploits, provocó alguno de los incidentes más recordados en el ámbito de la ciberseguridad como fue el caso de WannaCry.

Por ese motivo, este tipo de vulnerabilidades no deben ser tomadas a la ligera, ya que la capacidad que tienen los exploits que se preparan para aprovecharlas de propagarse rápidamente por redes que utilicen una versión vulnerable del protocolo es muy alta. Para evitarlo, es importante no solo actualizar lo antes posible a una versión que corrija este fallo, sino también aplicar una segmentación de redes que evite que un ataque consiga acceder a sistemas críticos de la organización.

Además, contar con una solución de seguridad capaz de detectar estos ataques de red y bloquearlos puede evitar graves daños, algo que ya se demostró en 2017 tras revisar la eficacia de varias soluciones de seguridad a la hora de bloquear el malware WannaCry.

Conclusión

La gestión de parches y actualizaciones es una tarea complicada por la gran cantidad de sistemas, protocolos y aplicaciones que se deben vigilar. No obstante, es importante prestar una atención especial a aquellas vulnerabilidades como las descritas en este artículo por los graves daños que pueden ocasionar si se explotan y solucionarlas lo antes posible.

Josep Albors

Comentar

Tu dirección de correo electrónico no será publicada.

Acerca de las cookies en este sitio

Este sitio web utiliza cookies propias y de terceros para mejorar tu experiencia de usuario y obtener información estadística. Para poder seguir navegando pulsa en "Sí, estoy de acuerdo". Podrás retirar este consentimiento en cualquier momento a través de las funciones de tu navegador. Ver nuestra política de cookies..