Vulnerabilidad en WhatsApp permitiría infectar dispositivos móviles

Cuando hablamos de seguridad en nuestros dispositivos móviles demasiadas veces se tiende a minimizar el posible impacto que un ataque puede ocasionar si lo comparamos con los ordenadores de sobremesa y portátiles que utilizamos en nuestro lugar de trabajo o a nivel personal. Sin embargo, si repasamos la cantidad de información que almacenamos o a la que accedemos desde nuestro smartphone entenderemos porqué son uno de los objetivos preferidos de los atacantes y, por ello, debemos protegerlos adecuadamente.

WhatsApp como vector de entrada de ataques

Siendo de las aplicaciones más instalada a nivel mundial y la líder en servicios de mensajería instantánea en varias regiones, no es de extrañar que cualquier agujero de seguridad relacionado con WhatsApp tenga especial relevancia. Por ese motivo, noticias como el reciente parcheo de una vulnerabilidad en esta aplicación nos deben servir como recordatorio de la importancia de mantener seguros y actualizados tanto nuestros dispositivos móviles como las aplicaciones que usamos a diario.

Con respecto a la vulnerabilidad en WhatsApp solucionada de forma silenciosa durante el pasado mes de octubre y con el código CVE-2019-11931 estamos ante un problema del tipo “stack-based buffer overflow”, provocado por la forma en la que las versiones vulnerables de WhatsApp procesa el flujo elemental de metadatos de un archivo MP4 (usados normalmente para visualizar vídeos).

Un atacante que se aprovechase de esta vulnerabilidad podría provocar una denegación de servicio o incluso la ejecución remota de código, comprometiendo la seguridad del dispositivos afectado y de la información almacenada. Para ello, tan solo necesitaría saber el número de teléfono de su objetivo y enviarles un archivo MP4 especialmente modificado que terminase instalando código malicioso como spyware o puertas traseras que permitiesen el acceso del atacante al dispositivo.

Impacto y solución al problema

Cuando se publica una vulnerabilidad de este tipo siempre nos preguntamos si, antes de ser descubierta ha podido ser utilizada de forma maliciosa por algunos atacantes. En esta ocasión y siempre según la versión de los desarrolladores de WhatsApp, no hay indicios que sugieran la realización de ataques aprovechando este agujero de seguridad.

Sin embargo, esto no significa que no debamos adoptar medidas para evitar ver la seguridad de nuestro dispositivo móvil comprometida. Así pues si disponemos de una versión anterior a la 2.19.274 en nuestro dispositivo Android o de la 2.19.100 en iOS recomendamos encarecidamente actualizar WhatsApp a la versión más reciente.

Mantener nuestras aplicaciones y sistema actualizados suele ser algo muy recomendable puesto que no solo recibiremos a menudo nuevas funcionalidades sino que también, como en este caso, solucionaremos aquellos errores y agujeros de seguridad que pueden provocarnos serios problemas de no hacerlo.

Conclusión

A la hora de gestionar la seguridad de nuestros dispositivos móviles es muy importante saber que aplicaciones tenemos instaladas y si existe alguna vulnerabilidad que pueda poner en riesgo la información almacenada o a la que accedemos desde él. Por ese motivo es muy recomendable revisar periódicamente las apps instaladas, actualizarlas y descartar aquellas que ya no usemos para evitar que sean usadas como vectores de ataque.

Josep Albors

Comentar

Tu dirección de correo electrónico no será publicada.

Acerca de las cookies en este sitio

Este sitio web utiliza cookies propias y de terceros para mejorar tu experiencia de usuario y obtener información estadística. Para poder seguir navegando pulsa en "Sí, estoy de acuerdo". Podrás retirar este consentimiento en cualquier momento a través de las funciones de tu navegador. Ver nuestra política de cookies..